OBIEE RPD Consistency Error – The feature in Database do not match the defaults

Moving development form database to database, I frequently end up with Warning: "OBIEE RPD – The feature in Database do not match the defaults. This can cause problems."  I assume this can be attributed to all these database (and servers) having slightly different settings, defaults, connections properties.  Sometimes I move databases and it does warning does not show up. Sometimes it does.

I am certain I am not alone with the following screen:

Image(16)

Poking around BI Administration, I was able to ‘remove’ this warning by doing something similar to the following:

1. On physical layer, check out database.

2. Right click database, then select properties.

Image(17)

3. Select "Query DBMS".

Checking consistency, warning seems to be gone now.

Image(18)

This may or not work for your case.  It worked for me.  If you this you messed up, you can always select  ‘Reset to defaults’ and go back to square one.

Good luck!

Advertisements

3 thoughts on “OBIEE RPD Consistency Error – The feature in Database do not match the defaults

  1. Mario, is there a way to export to a file (xls, csv –) the ‘properties ‘ in step 2 so we know what changes have been done? Thank you

    • Hello Elena,

      Not that I know. Unfortunately, I haven’t found any alternatives… These products are very dynamic thou, I wouldn’t be surprised additional features will ease some of these issues.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s